Webdiver - webdiver.ehs.ucsb.edu is down
Incident Report for UCSB-ARIT
Resolved
This incident has been resolved.
Posted Sep 23, 2020 - 19:29 PDT
Investigating
Service Outage Notification
Posted Sep 23, 2020 - 18:57 PDT