Stay at The Club and Guest House - stay.theclub.ucsb.edu/ is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Oct 21, 2020 - 23:18 PDT
Investigating
Service Outage Notification
Posted Oct 21, 2020 - 23:17 PDT