staffapps.arit.ucsb.edu is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Sep 13, 2021 - 15:58 PDT
Investigating
Service Outage Notification
Posted Sep 13, 2021 - 15:56 PDT