Facilities Public Web Site is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Oct 18, 2020 - 03:25 PDT
Investigating
Service Outage Notification
Posted Oct 18, 2020 - 03:23 PDT