Hazwaste - hazwaste.ehs.ucsb.edu is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Jun 20, 2020 - 18:40 PDT
Investigating
Service Outage Notification
Posted Jun 20, 2020 - 18:34 PDT