Legacy WebApps - appl.housing.ucsb.edu is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Jan 12, 2020 - 04:27 PST
Investigating
Service Outage Notification
Posted Jan 12, 2020 - 04:25 PST