Hazwaste - hazwaste.ehs.ucsb.edu is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Sep 26, 2021 - 17:18 PDT
Investigating
Service Outage Notification
Posted Sep 26, 2021 - 16:51 PDT