Hazwaste - hazwaste.ehs.ucsb.edu is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Oct 21, 2020 - 23:19 PDT
Investigating
Service Outage Notification
Posted Oct 21, 2020 - 23:17 PDT