CardSmith is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Sep 19, 2021 - 17:27 PDT
Investigating
Service Outage Notification
Posted Sep 19, 2021 - 16:49 PDT