Student Resource Building (Bldg 221) - Heating Hot Water (Unplanned Outage)
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 08:48 PDT
Identified
The heating hot water in SRB (Bldg 221) is currently turned off for urgent repairs to a water heater. We expect the repairs to be completed by end of day today, Wednesday, April 24th, after which hot water and heating services will be restored. Thank you for your patience during this maintenance period.
Posted Apr 24, 2024 - 08:31 PDT
This incident affected: CAMPUS BUILDINGS (Student Resource Building - UCSB Building 221).