Marine Biotechnology Lab (Bldg 555) - Water Valve Installation (Noise Alert)
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted May 03, 2024 - 10:45 PDT
Update
Due to a delay in receiving necessary parts, the previously scheduled water shutdown at Building 550 has been postponed. We now anticipate that the shutdown will occur on either Wednesday or Thursday of this week.

The restrooms in Building 550 will be closed during the shutdown, and the nearest available restrooms will continue to be on the 1st floor of Building 555, Marine Bio Lab.
Posted Apr 29, 2024 - 10:21 PDT
Update
As part of the ongoing installation of a water valve between the Marine Biotechnology Lab (Bldg 555) and Reservoir House (Bldg 205), the contractor will continue excavation work next week.

Please note that at some point during the day on Monday, April 29th, the water will be temporarily shut off at Building 550, resulting in the temporary closure of restrooms at Campus Point Beach. The nearest available restrooms are located on the 1st floor of the Marine Biotechnology Lab (Bldg 555).

While no other services will be disrupted, please expect some noise in the area while work is in progress. We appreciate your understanding during this project.
Posted Apr 26, 2024 - 15:14 PDT
Identified
A contractor is digging to install a water valve between Marine Biotechnology Lab (Bldg 555) and Reservoir House (Bldg 205) on Wednesday, April 24th. No services will be disrupted, but there will be noise in the area while work is in progress.
Posted Apr 24, 2024 - 10:39 PDT
This incident affected: CAMPUS BUILDINGS (Marine Biotechnology Lab - UCSB Building 555).