VDI Portal NHDC - vdi.arit.ucsb.edu is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 19:22 PDT
Investigating
Service Outage Notification
Posted Apr 23, 2024 - 19:16 PDT