Bldg 235 - Life Science Building - Restroom 1102 Closure

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Feb 02, 2024 - 09:15 PST

Identified

The repairs in restroom 1102 are currently in progress, with estimated project completion and reopening within one to two weeks.
Posted Jan 08, 2024 - 15:47 PST

Investigating

Restroom 1102 is currently closed for maintenance due to identified issues with a floor drain. The repairs, including potential plumbing and retiling, are expected to take a minimum of two weeks pending further investigation.

During the repairs, the closest alternative women's restroom is located on the second floor in Room 2102.

We appreciate your understanding as we work to address and resolve this issue.
Posted Dec 01, 2023 - 08:29 PST
This incident affected: CAMPUS BUILDINGS (Life Science - UCSB Building 235).