SAASB (Bldg 568) - Elevator 2 Out of Service

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 11:15 PST

Identified

Student Affairs & Administrative Services (Bldg 568) Elevator 2 is temporarily out of service while maintenance work is performed.

Our teams have been actively working on the elevator repair and are currently awaiting delivery of a required replacement part. Once the part is received, we will proceed with the repair and restore the elevator to service as quickly as possible.

If you have any questions or concerns, please contact Ray Gonzales, FM Superintendent for Life Safety Services, at 805-451-8993.
Posted Jan 21, 2026 - 16:01 PST
This incident affected: CAMPUS BUILDINGS (Student Affairs & Administrative Services - UCSB Building 568).