The Club and Guest House - www.theclub.ucsb.edu/ is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 22:04 PST
Investigating
Service Outage Notification
Posted Nov 19, 2024 - 21:30 PST