RMS Mercury Admin Portal - resportal.housing.ucsb.edu is down

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 12:17 PDT

Investigating

Service Outage Notification
Posted Mar 30, 2026 - 09:37 PDT
This incident affected: Mercury (RMS).