South Hall (Bldg 528) - Elevators 2 Out of Service

Incident Report for UCSB Administrative Services

Update

Elevator 4 is back in service.
Posted Feb 03, 2026 - 12:01 PST

Identified

South Hall (Bldg 528) Elevators 2 & 4 are temporarily out of service while maintenance work is performed.

If you have any questions or concerns, please contact Ray Gonzales, FM Superintendent for Life Safety Services, at 805-451-8993.
Posted Feb 02, 2026 - 15:09 PST
This incident affects: CAMPUS BUILDINGS (South Hall - UCSB Building 528).