Conferences Meet - meet.housing.ucsb.edu is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Sep 30, 2020 - 05:14 PDT
Investigating
Service Outage Notification
Posted Sep 30, 2020 - 05:03 PDT
This incident affected: Kx Registration.