Conferences Meet - meet.housing.ucsb.edu is down

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Mar 23, 2025 - 07:39 PDT

Investigating

Service Outage Notification
Posted Mar 23, 2025 - 07:30 PDT
This incident affected: Kx Registration.