Broida Hall (Bldg 572) - Elevators 1 & 2 (Scheduled Outage)

Scheduled for Apr 19, 06:00 - 18:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 02, 2025 - 15:51 PDT

Scheduled

Elevators 1 and 2 at Broida Hall (Bldg 572) will be out of service on Saturday, April 19 from 6AM to 6PM while maintenance is performed as part of the ongoing modernization project.

Elevator access will be unavailable for all floors in the five-story section, and stairwells will be the only means of access during this time. Intermittent loud noise is expected throughout the day due to concrete cutting and related work. The lobby will remain protected and will be cleaned during and after the work.

Occupants and visitors are strongly encouraged to avoid the five-story section during the outage.

For questions or concerns, please contact James Gonzales at (805) 451-9307
Posted Apr 02, 2025 - 15:50 PDT
This scheduled maintenance affects: CAMPUS BUILDINGS (Broida Hall - UCSB Building 572).