Bren Hall (Bldg 521) - Interruption of Recycled Water Service

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 15:10 PDT

Identified

Goleta Water District is currently performing emergency maintenance on the recycled water system, resulting in a temporary interruption of water service to the Bren Hall restrooms that utilize recycled water.

Maintenance is currently in progress. We will provide updates as they become available.
Posted Jun 25, 2026 - 13:41 PDT
This incident affected: CAMPUS BUILDINGS (Bren Hall - UCSB Building 521).