NetNutrition - netnutrition.housing.ucsb.edu is down
Incident Report for UCSB-ARIT
Resolved
This incident has been resolved.
Posted Sep 25, 2020 - 08:25 PDT
Investigating
Service Outage Notification
Posted Sep 24, 2020 - 13:59 PDT
This incident affected: CBORD.