CardSmith is down

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 04:04 PST

Investigating

Service Outage Notification
Posted Nov 12, 2025 - 03:48 PST