HDAE - www.hdae.ucsb.edu is down

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 11:24 PDT

Investigating

Service Outage Notification
Posted Apr 01, 2025 - 11:16 PDT