Facilities Public Web Site - dfss.ucsb.edu is down

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 07:03 PDT

Investigating

Service Outage Notification
Posted Mar 28, 2025 - 07:02 PDT