HDAE - www.hdae.ucsb.edu is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Mar 29, 2024 - 18:15 PDT
Investigating
Service Outage Notification
Posted Mar 29, 2024 - 18:13 PDT