Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Nov 14, 2024 - 07:48 PST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 14, 2024 - 07:00 PST
Scheduled
Date: November 14 to November 15, 2024 Time: 7AM to 4PM intermittently
FM Preventative Maintenance staff will be performing scheduled preventative maintenance work on the building’s heating, ventilating and air conditioning (HVAC) systems. This work includes inspection and replacement of air filtration media and fan motor belts, lubrication of motors, and inspection/repair of associated ventilation and hydronic heating and cooling systems. -------------------------------------------------------------------------------------------- Thursday November 14, 2024 Supply Fan 1 will be off before normally scheduled hours --------------------------------------------------------------------------------------------
Please contact Michael Lindner, Facilities Management Preventative Maintenance Superintendent with any questions of concerns: michael.lindner@ucsb.edu.
Posted Nov 02, 2024 - 09:41 PDT
This scheduled maintenance affected: CAMPUS BUILDINGS (Campbell Hall - UCSB Building 538).