The Club and Guest House - www.theclub.ucsb.edu/ is down

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 06:47 PST

Investigating

Service Outage Notification
Posted Nov 18, 2025 - 05:12 PST