Library Tower Partial Power Service Interruption

Incident Report for UCSB Administrative Services

Update

We are continuing to investigate this issue.
Posted Mar 28, 2025 - 12:35 PDT

Investigating

Due to a failed transformer, a number of receptacles and lights on Floors 7 and 8 are currently out of service. Facilities Management is currently working on a repair.
Posted Mar 28, 2025 - 12:22 PDT
This incident affects: CAMPUS BUILDINGS (Library - UCSB Building 525).