Engineering II Cooling Outage

Incident Report for UCSB Administrative Services

Resolved

The leak has been repaired and cooling is restored.
Posted Mar 27, 2025 - 12:44 PDT

Investigating

Facilities Management has identified a leak in the building's chilled water distribution system and has isolated the building from the campus chilled water loop in order to make repairs.
Posted Mar 27, 2025 - 10:50 PDT
This incident affected: CAMPUS BUILDINGS (Engineering II - UCSB Building 503).