Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 20, 2023 - 05:00 PST
Scheduled
Facilities Management will be performing work on the hydronic heating circuits in Chemistry and Physical Sciences North beginning at 5AM on Monday November 20, and concluding on or before 5PM on Wednesday, November 29th, 2023. During this time, there will be limited heating supplied to both buildings. This work is in preparation for a major heating plant upgrade. Your patience is appreciated. --------------------------------------------------------------------------------------------
Please contact Michael Lindner, Facilities Management Preventative Maintenance Superintendent with any questions of concerns: michael.lindner@ucsb.edu.
Posted Nov 17, 2023 - 11:43 PST
This scheduled maintenance affected: CAMPUS BUILDINGS (Chemistry - UCSB Building 557, Physical Sciences North - UCSB Building 657).