Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 27, 2023 - 07:00 PST
Scheduled
Date: November 27 to November 29, 2023 Time: 7AM to 4PM intermittently
FM Preventative Maintenance staff will be performing scheduled preventative maintenance work on the building’s heating, ventilating and air conditioning (HVAC) systems. This work includes inspection and replacement of air filtration media and fan motor belts, lubrication of motors, and inspection/repair of associated ventilation and hydronic heating and cooling systems. -------------------------------------------------------------------------------------------- All HVAC will be serviced - Monday November 27 to Wednesday November 29 before normally occupied hours.
-------------------------------------------------------------------------------------------- Wednesday November 29, 2023 Emergency Generator will be tested from 7AM to 8AM All electrical equipment connected to emergency power will be affected.
-------------------------------------------------------------------------------------------- Please contact Michael Lindner, Facilities Management Preventative Maintenance Superintendent with any questions of concerns: michael.lindner@ucsb.edu.
Posted Nov 20, 2023 - 13:36 PST
This scheduled maintenance affected: CAMPUS BUILDINGS (Multi-Activity Center - UCSB Building 511).