Webdiver - webdiver.ehs.ucsb.edu is down

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Dec 03, 2023 - 17:25 PST

Investigating

Service Outage Notification
Posted Dec 03, 2023 - 16:46 PST