WebTMA 7 - TEST is down

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Jan 08, 2026 - 09:06 PST

Investigating

Service Outage Notification
Posted Jan 08, 2026 - 01:01 PST
This incident affected: iService Desk - WebTMA.