BioEngineering Bldg. 512 - Interruption of Ventilation, Heating, Cooling and Exhaust

Scheduled for Jun 4, 05:00 PDT  -  Jun 11, 14:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 04, 2026 - 06:18 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted May 29, 2026 - 08:37 PDT

Scheduled

Bio Engineering Bldg. 512 - Interruption of Ventilation, Heating, Cooling and Exhaust


Date: June 4 to June 11, 2026
Time: 5:00AM to 2:00PM intermittently

FM Preventative Maintenance staff will be performing scheduled preventative maintenance work on the building’s heating, ventilating and air conditioning (HVAC) systems. This work includes inspection and replacement of air filtration media and fan motor belts, lubrication of motors, and inspection/repair of associated ventilation and hydronic heating and cooling systems.

Thursday June 4, 2026
AHU-1 will be off 5am to 9:00 am
EF-9 will be down 5:00am to 9:00 am (Serves Cage Wash Dirty Side 0304 & Clean Side 0505)
EF-12 will be off 5:00am to 9:00 am (Serves Cage Washer & 0302 BSC C1)
EF-1 will be off 9 am to Noon
EF-2 will be off 9am to Noon
Vacuum system will be serviced from 8:00AM – 12:00PM
--------------------------------------------------------------------------------------------
Friday June 5, 2026
EF-8 will be down from 5am to 9am (Serves Loading Dock 1309)
EF-11 will be down from 5am to 9 am
Compressed Air system will be serviced from 8:00AM – 12:00PM
--------------------------------------------------------------------------------------------
Wednesday June 10, 2026

Emergency Generator will be tested from 7:30AM – 8:30AM
Backup Chiller will be tested from 7:30AM to 8:30AM
--------------------------------------------------------------------------------------------
Please contact Michael Lindner, Facilities Management Preventative Maintenance Superintendent with any questions of concerns: michael.lindner@ucsb.edu.
Posted May 27, 2026 - 21:40 PDT
This scheduled maintenance affects: CAMPUS BUILDINGS (BioEngineering - UCSB Building 512).