Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 04, 2023 - 07:00 PST
Scheduled
Date: December 4 to December 6, 2023 Time: 7AM to 4PM intermittently
FM Preventative Maintenance staff will be performing scheduled preventative maintenance work on the building’s heating, ventilating and air conditioning (HVAC) systems. This work includes inspection and replacement of air filtration media and fan motor belts, lubrication of motors, and inspection/repair of associated ventilation and hydronic heating and cooling systems. -------------------------------------------------------------------------------------------- All HVAC will be serviced - Monday December 4 to December 6, before normally occupied hours.
-------------------------------------------------------------------------------------------- Wednesday December 6, 2023 Emergency Generator will be tested from 7AM to 8AM
-------------------------------------------------------------------------------------------- Please contact Michael Lindner, Facilities Management Preventative Maintenance Superintendent with any questions of concerns: michael.lindner@ucsb.edu.
Posted Nov 20, 2023 - 13:30 PST
This scheduled maintenance affected: CAMPUS BUILDINGS (Recreation Center - UCSB Building 516).