Clearpass is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 06:45 PDT
Investigating
Service Outage Notification
Posted Apr 10, 2024 - 05:41 PDT