Life Science (Bldg #235) - Building Heating Hot Water (Outage)

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Nov 21, 2024 - 07:59 PST

Identified

The building heating hot water in Life Science (Bldg 235) is currently turned off for urgent repairs. We expect the repairs to be completed by 4:00pm on Wednesday, November 20th after which building heating services are expected to be restored.

If you have any questions, please contact Mike Smiyun, Facilities Management Sr. Superintendent for HVAC at 805-451-8990
Posted Nov 19, 2024 - 15:05 PST
This incident affected: CAMPUS BUILDINGS (Life Science - UCSB Building 235).