Bio Science Bldg 504 - Storm Drain Repair (Noise Alert)
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 07:49 PDT
Monitoring
The maintenance work on the storm drain between Bio Science (Bldg 504) and Life Science (Bldg 235) has been successfully completed. Concrete pouring is scheduled for today to finalize the repairs.

Please be advised that the sidewalk area will reopen for foot traffic on Monday, April 8th. We appreciate your patience and cooperation throughout this process.
Posted Apr 05, 2024 - 13:06 PDT
Identified
A contractor is working on a storm drain between Bio Science Bldg 504 and Life Science Building 235 on Monday, April 1st. No services will be disrupted, but there will be noise in the area while work is in progress.
Posted Apr 01, 2024 - 07:57 PDT
This incident affected: CAMPUS BUILDINGS (Bio Sci Instruction Facility - UCSB Building 504, Life Science - UCSB Building 235).