CardSmith is down

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 03:02 PDT

Investigating

Service Outage Notification
Posted Jul 07, 2025 - 23:46 PDT