Conferences Meet - meet.housing.ucsb.edu is down

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted May 08, 2026 - 02:10 PDT

Investigating

Service Outage Notification
Posted May 08, 2026 - 02:05 PDT
This incident affected: Kx Registration.