HDAE - www.hdae.ucsb.edu is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Nov 17, 2024 - 17:21 PST
Investigating
Service Outage Notification
Posted Nov 17, 2024 - 17:20 PST