Facilities Public Web Site is down
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Sep 30, 2020 - 05:24 PDT
Investigating
Service Outage Notification
Posted Sep 30, 2020 - 05:23 PDT