Chilled Water Service Interruption - Multiple Buildings
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted May 08, 2024 - 13:54 PDT
Update
Work will begin to excavate and identify the cause of the damaged chilled water loop infrastructure on Tuesday, May 7th.

One lane of Ocean Road will be closed to through traffic while work is being done on the repairs.

Additional updates will be shared as they are available.
Posted May 06, 2024 - 14:52 PDT
Investigating
Chilled water service has been interrupted on the West side of the main campus. Cooling will be unavailable at the following buildings until the issue is identified and repairs can be implemented:

Events Center Bldg. 505
Humanities & Social Sciences Bldg. 515
Student Resources Bldg. 221
Theater & Dance East Bldg 554
Theater & Dance West Bldg. 223

Updates will be dispatched as they are available.
Posted Apr 19, 2024 - 14:58 PDT
This incident affected: CAMPUS INFRASTRUCTURE (Chilled Water Loop) and CAMPUS BUILDINGS (Events Center - UCSB Building 505, Humanities & Social Sciences - USCB Building 515, Student Resource Building - UCSB Building 221, Theater & Dance East - UCSB Building 554, Theater & Dance West - UCSB Building 223).