Engineering II (Bldg 503) - Supply Fan Outage

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 08:15 PDT

Identified

Engineering II (Bldg 503) Supply Fan S-5 is currently turned off while Facilities Management (FM) works to repair the system.

If you have any questions or concerns, please contact Mike Smiyun, FM HVAC Sr. Superintendent, at (805) 451-8990
Posted May 26, 2026 - 11:01 PDT
This incident affected: CAMPUS BUILDINGS (Engineering II - UCSB Building 503).