Elings Hall (Bldg 266) - Elevator #2 Out of Service

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 07:49 PDT

Investigating

Bldg 266 Elings Hall south Elevator #2 is temporarily out of service until further notice while maintenance work is performed.

If you have any questions or concerns, please contact Ray Gonzales, FM Superintendent for Life Safety Services, at 805-451-8993
Posted May 28, 2025 - 09:22 PDT
This incident affected: CAMPUS BUILDINGS (Elings Hall - UCSB Building 266).