HSSB Bldg 515 - Hot Water Outage
Incident Report for UCSB Administrative Services
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 10:52 PDT
Identified
Please be informed that the hot water service for the Humanities and Social Sciences Building (515) is currently turned off due to ongoing repairs to the boilers. We anticipate that the hot water will remain unavailable for approximately two weeks while these repairs are completed.

We apologize for any inconvenience this temporary interruption may cause and sincerely appreciate your patience and understanding during this maintenance period.
Posted Mar 13, 2024 - 13:42 PDT
This incident affected: CAMPUS BUILDINGS (Humanities & Social Sciences - USCB Building 515).