Hot Water Outage at Building 534 Arts

Incident Report for UCSB Administrative Services

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 16, 2025 - 08:27 PDT

Investigating

Service Alert – Hot Water Outage at Building 534 Arts

Please be advised that Building 534 Arts is currently without hot water due to an equipment issue. Repairs are pending the arrival of ordered parts. We will provide updates as soon as more information becomes available.
If you have any question or concerns please contact the Plumbing Superintendent Mark Irwin at 805-722-8397 or email mark.irwin@pf.ucsb.edu

We apologize for the inconvenience and appreciate your patience.
Posted Jul 16, 2025 - 07:44 PDT
This incident affects: CAMPUS BUILDINGS (Arts - UCSB Building 534).