We will be undergoing scheduled maintenance during this time.
Posted Sep 17, 2026 - 17:49 PDT
Scheduled
Webb Hall Bldg. 526 - Interruption of Ventilation, Heating, Cooling and Exhaust
Date: September 22 to September 25, 2026 Time: 7am to 4pm intermittently
FM Preventative Maintenance staff will be performing scheduled preventative maintenance work on the building’s heating, ventilating and air conditioning (HVAC) systems. This work includes inspection and replacement of air filtration media and fan motor belts, lubrication of motors, and inspection/repair of associated ventilation and hydronic heating and cooling systems. Maintenance for all supply fans will be performed outside or regular building schedule. Please contact Michael Lindner, Facilities Management Preventative Maintenance Superintendent with any questions of concerns: michael.lindner@ucsb.edu. AHU-1 will be off September 22, 2026 from 7am to 12 noon. AHU-2 will be off September 22, 2026 from 1 to 4 pm (Both serve Trace Metal Lab)
LEE-1 will be off September 23, 2026 from 6 am to 10 am LEE-2 will be off September 23, 2026 10 am to 2 pm Exhaust for Trace Metal.
Emergency Generator will be tested September 23 at 7:30 am to 8:30 am, provides power to emergency circuits for Trace Metal Lab.
House Air will be off September 24, 2026 at 9am to 12noon House Vacuum will be off September 24, 2026 from 1pm to 4pm
Please contact Michael Lindner, Facilities Management Preventative Maintenance Superintendent with any questions of concerns: michael.lindner@ucsb.edu.
Posted Sep 17, 2026 - 17:22 PDT
This scheduled maintenance affects: CAMPUS BUILDINGS (Webb Hall - UCSB Building 526).