Library Elevator Service Outage

Incident Report for UCSB Administrative Services

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 12:34 PDT

Investigating

Library elevators 1,2, and 3 are currently out of service. Facilities Management is investigating. Additional updates will be posted as the issue is addressed.
Posted Mar 28, 2025 - 12:19 PDT
This incident affected: CAMPUS BUILDINGS (Library - UCSB Building 525).